GreatSQL社区

搜索

[已解决] greatsql 5.7搭建的mgr集群,要用什么版本的mysqlrouter?

75 8 2024-7-5 11:40
本帖最后由 驭无殇1998 于 2024-7-5 17:34 编辑

如题:

5.7版本的可以使用8.0版本的mysqlrouter?或者使用proxysql进行代理访问?




经初步测试,使用8.0版本的mysql-shell配合mysql-router可以实现。
全部回复(8)
yejr 2024-7-5 13:59:54
5.7 已经EOL的,改用 8.0 吧
非要用 GreatSQL 5.7 跑 MGR 的话,那就用 8.0 的 Router 或 ProxySQL 试试看
驭无殇1998 2024-7-5 15:19:02
yejr 发表于 2024-7-5 13:59
5.7 已经EOL的,改用 8.0 吧
非要用 GreatSQL 5.7 跑 MGR 的话,那就用 8.0 的 Router 或 ProxySQL 试试看 ...

就是不能升级版本我才过来问,一个老系统,不敢升级,以前的开发都不在了,现在的开发都不想碰这玩意,之前是部署在云上的,用的云数据库,所以不用管高可用。

上个星期迁到本地,然后就要自己搭建集群进行维护了。所以就考虑到mgr集群比较方便嘛,就想问问有没有合适的代理选择,哎。
banjin 2024-7-5 16:03:38
驭无殇1998 发表于 2024-7-5 15:19
就是不能升级版本我才过来问,一个老系统,不敢升级,以前的开发都不在了,现在的开发都不想碰这玩意,之 ...

先做个测试环境验证一下,没问题的话再上生产
驭无殇1998 2024-7-5 16:23:05
banjin 发表于 2024-7-5 16:03
先做个测试环境验证一下,没问题的话再上生产

嗯,正是这么打算的,哈哈哈哈
yejr 2024-7-5 17:28:52
驭无殇1998 发表于 2024-7-5 15:19
就是不能升级版本我才过来问,一个老系统,不敢升级,以前的开发都不在了,现在的开发都不想碰这玩意,之 ...

没开发支持,不敢升版本的系统,最好也别折腾迁移到MGR了
驭无殇1998 2024-7-5 17:33:52
yejr 发表于 2024-7-5 17:28
没开发支持,不敢升版本的系统,最好也别折腾迁移到MGR了

要求要有高可用,等保要求的。除了mgr,好像就只有mha了

还好,看过表都有主键,应该可以直接搞过来。刚在测试环境整了一下,没啥问题。

mysql-shell8.0的可以支持5.7的mgr集群创建,8.0的mysqlrouter也可以进行代理
reddey 2024-7-5 20:09:53
驭无殇1998 发表于 2024-7-5 17:33
要求要有高可用,等保要求的。除了mgr,好像就只有mha了

还好,看过表都有主键,应该可以直接搞过来。刚 ...

如果你测试了没问题就行,没有开发人员支持的系统对运维来说比较麻烦。
一个学艺不精的国产数据库爱好者
驭无殇1998 2024-7-8 09:10:05
reddey 发表于 2024-7-5 20:09
如果你测试了没问题就行,没有开发人员支持的系统对运维来说比较麻烦。 ...

嗯嗯,先用备份数据跑起来看看有没有异常,哈哈哈哈
驭无殇1998

18

主题

0

博客

146

贡献

中级会员

Rank: 3Rank: 3

积分
241

勤学好问(铜)助人为乐(银)

合作电话:010-64087828

社区邮箱:greatsql@greatdb.com

社区公众号
社区小助手
QQ群
GMT+8, 2024-7-16 20:43 , Processed in 0.021029 second(s), 19 queries , Redis On.
快速回复 返回顶部 返回列表